Home Page Forums Raspberry Pi Shields Quectel EC25 Mini PCle 4G/LTE Module not connecting

This topic contains 16 replies, has 5 voices, and was last updated by  Saeed 4 days, 14 hours ago.

Viewing 15 posts - 1 through 15 (of 17 total)
  • Author
    Posts
  • #36474

    Manuel Rodriguez
    Participant

    Hello,

    I have the Quectel EC25 Mini PCle 4G/LTE, I’m not able to connect, I followed the steps of the tutorial of ppp conection, but when i write in command “sudo pon” i get the following error. ( I have on red light of power and the blue light is blinking).

    [email protected]:~ $ sudo pon
    pppd options in effect:
    debug # (from /etc/ppp/peers/provider)
    updetach # (from /etc/ppp/peers/provider)
    dump # (from /etc/ppp/peers/provider)
    noauth # (from /etc/ppp/peers/provider)
    remotename 3gppp # (from /etc/ppp/peers/provider)
    /dev/ttyUSB3 # (from /etc/ppp/peers/provider)
    115200 # (from /etc/ppp/peers/provider)
    lock # (from /etc/ppp/peers/provider)
    connect chat -s -v -f /etc/chatscripts/chat-connect -T movistar.es # (from /etc/ppp/peers/provider)
    disconnect chat -s -v -f /etc/chatscripts/chat-disconnect # (from /etc/ppp/peers/provider)
    nocrtscts # (from /etc/ppp/peers/provider)
    modem # (from /etc/ppp/peers/provider)
    asyncmap 0 # (from /etc/ppp/options)
    lcp-echo-failure 4 # (from /etc/ppp/options)
    lcp-echo-interval 30 # (from /etc/ppp/options)
    hide-password # (from /etc/ppp/peers/provider)
    novj # (from /etc/ppp/peers/provider)
    novjccomp # (from /etc/ppp/peers/provider)
    ipcp-accept-local # (from /etc/ppp/peers/provider)
    ipcp-accept-remote # (from /etc/ppp/peers/provider)
    ipparam 3gppp # (from /etc/ppp/peers/provider)
    noipdefault # (from /etc/ppp/peers/provider)
    ipcp-max-failure 30 # (from /etc/ppp/peers/provider)
    defaultroute # (from /etc/ppp/peers/provider)
    usepeerdns # (from /etc/ppp/peers/provider)
    noccp # (from /etc/ppp/peers/provider)
    noipx # (from /etc/ppp/options)
    abort on (BUSY)
    abort on (NO CARRIER)
    abort on (NO DIALTONE)
    abort on (ERROR)
    abort on (NO ANSWER)
    timeout set to 30 seconds
    send (AT^M)
    expect (OK)
    ^M
    OK
    — got it

    send (ATE0^M)
    expect (OK)
    ^M
    ^M
    OK
    — got it

    send (ATI;+CSUB;+CSQ;+COPS?;+CGREG?;&D2^M)
    expect (OK)
    ^M
    ^M
    Quectel^M
    EC25^M
    Revision: EC25EFAR06A03M4G^M
    ^M
    SubEdition: V03^M
    ^M
    +CSQ: 14,99^M
    ^M
    +COPS: 0^M
    ^M
    +CGREG: 0,2^M
    ^M
    OK
    — got it

    send (AT+CGDCONT=1,”IP”,”movistar.es”,,0,0^M)
    expect (OK)
    ^M
    ^M
    OK
    — got it

    send (ATD*99#^M)
    expect (CONNECT)
    ^M
    ^M
    CONNECT
    — got it

    Script chat -s -v -f /etc/chatscripts/chat-connect -T movistar.es finished (pid 2554), status = 0x0
    Serial connection established.
    using channel 32
    Using interface ppp0
    Connect: ppp0 <–> /dev/ttyUSB3
    sent [LCP ConfReq id=0x1 <asyncmap 0x0> <magic 0xa04e5141> <pcomp> <accomp>]
    rcvd [LCP ConfReq id=0x5d <asyncmap 0x0> <auth chap MD5> <magic 0xd129e40f> <pcomp> <accomp>]
    No auth is possible
    sent [LCP ConfRej id=0x5d <auth chap MD5>]
    rcvd [LCP ConfAck id=0x1 <asyncmap 0x0> <magic 0xa04e5141> <pcomp> <accomp>]
    rcvd [LCP ConfReq id=0x5e <asyncmap 0x0> <magic 0xd129e40f> <pcomp> <accomp>]
    sent [LCP ConfAck id=0x5e <asyncmap 0x0> <magic 0xd129e40f> <pcomp> <accomp>]
    sent [LCP EchoReq id=0x0 magic=0xa04e5141]
    sent [IPCP ConfReq id=0x1 <addr 0.0.0.0> <ms-dns1 0.0.0.0> <ms-dns2 0.0.0.0>]
    rcvd [LCP DiscReq id=0x5f magic=0xd129e40f]
    rcvd [LCP EchoRep id=0x0 magic=0xd129e40f a0 4e 51 41]
    Modem hangup
    Connection terminated.

    I think movistar in Spain needs access with user and password. But when I place it in the provider file, I have the following error.

    [email protected]:/etc/ppp/peers $ sudo pon
    /usr/sbin/pppd: The remote system (3gppp) is required to authenticate itself
    /usr/sbin/pppd: but I couldn’t find any suitable secret (password) for it to use to do so.

    Thanks in advance for the help.

    #36530

    Saeed
    Participant

    Hi,

    Please make sure the information provided such as APN, Username and Password are correct.

    Did you remove no auth from /etc/ppp/peers/provider .

    Best regards,

    #36576

    Manuel Rodriguez
    Participant

    Hi,
    I have reviewed the information of the APN and username and password, and it is correct.
    Also I have commented on that line. It has stayed like this:
    # noauth
    user “TELEFONICA”
    password “TELEFONICA”

    I’m new to Linux and I have no idea what the problem might be.
    I’m stuck here.

    [email protected]:/etc/ppp/peers $ sudo pon
    /usr/sbin/pppd: The remote system (3gppp) is required to authenticate itself
    /usr/sbin/pppd: but I couldn’t find any suitable secret (password) for it to use to do so.

    thanks,

    #36680

    florian.nadal
    Participant

    I also have the Quectel EC25-E (for Europe, I am near Paris with Orange as telecom operator) Mini PCle 4G/LTE with Raspberry Pi 3G-4G/LTE Base Shield V2. I’m not able to connect, I followed the steps of :
    https://frillip.com/using-your-raspberry-pi-3-as-a-wifi-access-point-with-hostapd/
    https://sixfab.com/ppp-installer-for-sixfab-shield/
    https://sixfab.com/updated-tutorial-3-make-a-ppp-internet-connection-with-3g-4glte-shields-on-raspberry-pi/

    and, when I try to connect, I get this :

    [email protected]:~ $ sudo pon
    pppd options in effect:
    debug # (from /etc/ppp/peers/provider)
    updetach # (from /etc/ppp/peers/provider)
    dump # (from /etc/ppp/peers/provider)
    noauth # (from /etc/ppp/peers/provider)
    remotename 3gppp # (from /etc/ppp/peers/provider)
    /dev/ttyUSB3 # (from /etc/ppp/peers/provider)
    115200 # (from /etc/ppp/peers/provider)
    lock # (from /etc/ppp/peers/provider)
    connect chat -s -v -f /etc/chatscripts/chat-connect -T orange # (from /etc/ppp/peers/provider)
    disconnect chat -s -v -f /etc/chatscripts/chat-disconnect # (from /etc/ppp/peers/provider)
    nocrtscts # (from /etc/ppp/peers/provider)
    modem # (from /etc/ppp/peers/provider)
    asyncmap 0 # (from /etc/ppp/options)
    lcp-echo-failure 4 # (from /etc/ppp/options)
    lcp-echo-interval 30 # (from /etc/ppp/options)
    hide-password # (from /etc/ppp/peers/provider)
    novj # (from /etc/ppp/peers/provider)
    novjccomp # (from /etc/ppp/peers/provider)
    ipcp-accept-local # (from /etc/ppp/peers/provider)
    ipcp-accept-remote # (from /etc/ppp/peers/provider)
    ipparam 3gppp # (from /etc/ppp/peers/provider)
    noipdefault # (from /etc/ppp/peers/provider)
    ipcp-max-failure 30 # (from /etc/ppp/peers/provider)
    defaultroute # (from /etc/ppp/peers/provider)
    usepeerdns # (from /etc/ppp/peers/provider)
    noccp # (from /etc/ppp/peers/provider)
    noipx # (from /etc/ppp/options)
    abort on (BUSY)
    abort on (NO CARRIER)
    abort on (NO DIALTONE)
    abort on (ERROR)
    abort on (NO ANSWER)
    timeout set to 30 seconds
    send (AT^M)
    expect (OK)
    ^M
    OK
    — got it

    send (ATE0^M)
    expect (OK)
    ^M
    ^M
    OK
    — got it

    send (ATI;+CSUB;+CSQ;+COPS?;+CGREG?;&D2^M)
    expect (OK)
    ^M
    ^M
    Quectel^M
    EC25^M
    Revision: EC25EFAR06A03M4G^M
    ^M
    SubEdition: V03^M
    ^M
    +CSQ: 15,99^M
    ^M
    +COPS: 0,0,”Orange F Orange F”,2^M
    ^M
    +CGREG: 0,1^M
    ^M
    OK
    — got it

    send (AT+CGDCONT=1,”IP”,”orange”,,0,0^M)
    expect (OK)
    ^M
    ^M
    OK
    — got it

    send (ATD*99#^M)
    expect (CONNECT)
    ^M
    ^M
    CONNECT
    — got it

    Script chat -s -v -f /etc/chatscripts/chat-connect -T orange finished (pid 2928), status = 0x0
    Serial connection established.
    using channel 33
    Using interface ppp0
    Connect: ppp0 <–> /dev/ttyUSB3
    sent [LCP ConfReq id=0x1 <asyncmap 0x0> <magic 0x82668b8d> <pcomp> <accomp>]
    rcvd [LCP ConfReq id=0x60 <asyncmap 0x0> <auth chap MD5> <magic 0x4bcff72e> <pcomp> <accomp>]
    No auth is possible
    sent [LCP ConfRej id=0x60 <auth chap MD5>]
    rcvd [LCP ConfAck id=0x1 <asyncmap 0x0> <magic 0x82668b8d> <pcomp> <accomp>]
    rcvd [LCP ConfReq id=0x61 <asyncmap 0x0> <magic 0x4bcff72e> <pcomp> <accomp>]
    sent [LCP ConfAck id=0x61 <asyncmap 0x0> <magic 0x4bcff72e> <pcomp> <accomp>]
    sent [LCP EchoReq id=0x0 magic=0x82668b8d]
    sent [IPCP ConfReq id=0x1 <addr 0.0.0.0> <ms-dns1 0.0.0.0> <ms-dns2 0.0.0.0>]
    rcvd [LCP DiscReq id=0x62 magic=0x4bcff72e]
    rcvd [LCP EchoRep id=0x0 magic=0x4bcff72e 82 66 8b 8d]
    rcvd [IPCP ConfNak id=0x1 <ms-dns1 10.11.12.13> <ms-dns2 10.11.12.14> <ms-wins 10.11.12.13> <ms-wins 10.11.12.14>]
    sent [IPCP ConfReq id=0x2 <addr 0.0.0.0> <ms-dns1 10.11.12.13> <ms-dns2 10.11.12.14> <ms-wins 10.11.12.13> <ms-wins 10.11.12.14>]
    Modem hangup
    Connection terminated.

    #36727

    Saeed
    Moderator

    Hi, are you sure about APN?
    Could you try orange.fr as APN?

    #36741

    florian.nadal
    Participant

    -> I tried orange.fr as APN …

    $ sudo nano /etc/ppp/peers/provider

    -> I replaced “connect ‘chat -s -v -f /etc/chatscripts/chat-connect -T orange'” by “connect ‘chat -s -v -f /etc/chatscripts/chat-connect -T orange.fr'”.

    $ sudo pon

    -> I get this …

    pppd options in effect:
    debug # (from /etc/ppp/peers/provider)
    updetach # (from /etc/ppp/peers/provider)
    dump # (from /etc/ppp/peers/provider)
    noauth # (from /etc/ppp/peers/provider)
    remotename 3gppp # (from /etc/ppp/peers/provider)
    /dev/ttyUSB3 # (from /etc/ppp/peers/provider)
    115200 # (from /etc/ppp/peers/provider)
    lock # (from /etc/ppp/peers/provider)
    connect chat -s -v -f /etc/chatscripts/chat-connect -T orange.fr # (from /etc/ppp/peers/provider)
    disconnect chat -s -v -f /etc/chatscripts/chat-disconnect # (from /etc/ppp/peers/provider)
    nocrtscts # (from /etc/ppp/peers/provider)
    modem # (from /etc/ppp/peers/provider)
    asyncmap 0 # (from /etc/ppp/options)
    lcp-echo-failure 4 # (from /etc/ppp/options)
    lcp-echo-interval 30 # (from /etc/ppp/options)
    hide-password # (from /etc/ppp/peers/provider)
    novj # (from /etc/ppp/peers/provider)
    novjccomp # (from /etc/ppp/peers/provider)
    ipcp-accept-local # (from /etc/ppp/peers/provider)
    ipcp-accept-remote # (from /etc/ppp/peers/provider)
    ipparam 3gppp # (from /etc/ppp/peers/provider)
    noipdefault # (from /etc/ppp/peers/provider)
    ipcp-max-failure 30 # (from /etc/ppp/peers/provider)
    defaultroute # (from /etc/ppp/peers/provider)
    usepeerdns # (from /etc/ppp/peers/provider)
    noccp # (from /etc/ppp/peers/provider)
    noipx # (from /etc/ppp/options)
    abort on (BUSY)
    abort on (NO CARRIER)
    abort on (NO DIALTONE)
    abort on (ERROR)
    abort on (NO ANSWER)
    timeout set to 30 seconds
    send (AT^M)
    expect (OK)
    AT^M^M
    OK
    — got it

    send (ATE0^M)
    expect (OK)
    ^M
    ATE0^M^M
    OK
    — got it

    send (ATI;+CSUB;+CSQ;+COPS?;+CGREG?;&D2^M)
    expect (OK)
    ^M
    ^M
    Quectel^M
    EC25^M
    Revision: EC25EFAR06A03M4G^M
    ^M
    SubEdition: V03^M
    ^M
    +CSQ: 17,99^M
    ^M
    +COPS: 0^M
    ^M
    +CGREG: 0,1^M
    ^M
    OK
    — got it

    send (AT+CGDCONT=1,”IP”,”orange.fr”,,0,0^M)
    expect (OK)
    ^M
    ^M
    OK
    — got it

    send (ATD*99#^M)
    expect (CONNECT)
    ^M
    ^M
    CONNECT
    — got it

    Script chat -s -v -f /etc/chatscripts/chat-connect -T orange.fr finished (pid 2784), status = 0x0
    Serial connection established.
    using channel 1
    Using interface ppp0
    Connect: ppp0 <–> /dev/ttyUSB3
    sent [LCP ConfReq id=0x1 <asyncmap 0x0> <magic 0xb51f92c3> <pcomp> <accomp>]
    rcvd [LCP ConfReq id=0x0 <asyncmap 0x0> <auth chap MD5> <magic 0x68ea770c> <pcomp> <accomp>]
    No auth is possible
    sent [LCP ConfRej id=0x0 <auth chap MD5>]
    rcvd [LCP ConfAck id=0x1 <asyncmap 0x0> <magic 0xb51f92c3> <pcomp> <accomp>]
    rcvd [LCP ConfReq id=0x1 <asyncmap 0x0> <magic 0x68ea770c> <pcomp> <accomp>]
    sent [LCP ConfAck id=0x1 <asyncmap 0x0> <magic 0x68ea770c> <pcomp> <accomp>]
    sent [LCP EchoReq id=0x0 magic=0xb51f92c3]
    sent [IPCP ConfReq id=0x1 <addr 0.0.0.0> <ms-dns1 0.0.0.0> <ms-dns2 0.0.0.0>]
    rcvd [LCP DiscReq id=0x2 magic=0x68ea770c]
    rcvd [LCP EchoRep id=0x0 magic=0x68ea770c b5 1f 92 c3]
    Modem hangup
    Connection terminated.

    #36743

    Saeed
    Moderator

    Which adapter are you using for powering your raspberry pi?

    #36752

    florian.nadal
    Participant

    I am using :
    -> Raspberry Pi 3G-4G/LTE Base Shield V2
    -> Quectel EC25 Mini PCle 4G/LTE Module – EC25-E
    -> and two mini antenna are plugged to the EC25 module

    I have also inserted a classic SIMcard for a 4G internet access. It works very well while I use it in a common Huawei wifi mini-router.

    I live in Paris, and the signal use to be very clean and strong where I test the sixfab device.

    #36827

    Saeed
    Moderator

    What are you using to power your Raspberry Pi?

    #36849

    florian.nadal
    Participant

    For the raspberry, I use the default power supply furnished with a raspberry engraved on it.
    For the base shield, I plug the mini USB adaptator to a USB port of the raspberry Pi.

    #36901

    Saeed
    Moderator

    Could you please try with a different SIM?

    #37041

    florian.nadal
    Participant

    I use a SIM that I am sure it is operational ; I use it with a Huawei 4g hotspot router (like the 4G E5786) and it works very well.

    It look like this (in french) : https://assistance.orange.fr/cle-domino/tous-les-cles-et-dominos/installer-et-utiliser/mettre-en-service/domino-huawei-4g-e5786-configurer-un-profil-de-connexion_64464-65311

    login : orange
    password : orange
    APN : orange.fr

    When I try … APN : “orange.fr” with …

    # noauth
    user “orange”
    password “orange”

    I get the same error as Manuel Rodriguez have :

    [email protected]:/etc/ppp/peers $ sudo pon
    /usr/sbin/pppd: The remote system (3gppp) is required to authenticate itself
    /usr/sbin/pppd: but I couldn’t find any suitable secret (password) for it to use to do so.

    #37055

    Saeed
    Moderator

    Please check how to set. PAP secret file.
    https://www.tldp.org/HOWTO/PPP-HOWTO/x1034.html

    #37131

    florian.nadal
    Participant

    Thank you a lot for the help Saeed ! It works !

    I solved the problem by removing the # before the line “noauth”, and I also removed USER “orange” + PASSWORD “orange” in /etc/ppp/peers/provider.

    Then I wrote this line “orange * orange -” in /etc/ppp/pap-secrets.

    The best tutorials I used are :

    https://frillip.com/using-your-raspberry-pi-3-as-a-wifi-access-point-with-hostapd/

    https://sixfab.com/ppp-installer-for-sixfab-shield/

    #37204

    Saeed
    Moderator

    That is great. Thank you for your feedback. 🙂

Viewing 15 posts - 1 through 15 (of 17 total)

You must be logged in to reply to this topic.